Bad request when executing Paginated Output

Hi All,

I’m working on a proces that converts xml’s to pdf in node-red, the datamapper, template, jobpreset works fine. The outputpreset is not working properly, i’ve mapped the Paginated Output, but getting an error:
16 Feb 14:13:47 - [info] [olcnr-paginated-output:97a0b15c8e116370] 240470107 240470108 POST http://ned-pp02-o:9340/rest/serverengine/workflow/outputcreation/getManagedResult/7870d7a8-e7d7-4dc6-b301-67b23786b1ac
16 Feb 14:13:47 - [info] [olcnr-paginated-output:97a0b15c8e116370] 240470107 240470108 400 Bad Request application/json 531 bytes
16 Feb 14:13:47 - [error] [olcnr-paginated-output:97a0b15c8e116370] olconnect.error.ESERVERSTATUSCODENOTEXPECTED
The preset is a working preset from our production server, the only thing i changed is the Job Output Folder because that used the JobInfo from workflow.

When i look in the folder: C:\Users\apl_pp02-o\Connect\filestore i see that the pdf’s are created correctly, only not placed in the right directory…

Any help on this topic is very welcome.

Kind regards,

Ted van Roon
Nedasco BV

Hallo Ted,

In node-red the output files are not automatically downloaded and at this stage the Output Preset is not triggered to write the output files to the folder defined in the preset (this is on our backlog and will be added shortly [internal ref: NODERED-2387]).

At this stage you’ll need to handle this as part of the flow. This can either be the job as zip or download the output as individual files. Writing the zip from node-red would be a matter of adding a ‘write file’ node and specify the path in that step. By default the paginated output and all in one nodes write the result as buffer in msg.payload. This is a zip archive.

Happy to give your files a look. Would you be able to share your flow and resources (DM me)?



Quick update as we’ve discussed the topic offline. The problem was caused by a slash in the file name mask of the Output Preset, it was solved by replacing the slash with an underscore.

Hi @Erik,

Is there a requirement to uninstall the “OL Connect Automation setup”?
I’m trying to uninstall then install but I keep getting this error.


Haven’t seen this before but will ask our R&D department to look into it.

Hi James123456,

Could you retry after closing the node.exe via the Task Manager?


Hi @Erik,

That did not work. So ended up restarting the PC and it worked. I’m guessing is just being a little impentient :slight_smile:
Thank you.

1 Like