OL Learn

CFF Type 2 Font error

Hello,

I am testing PlanetPress Connect with Business inkjet printers. I have problem in PostScript printing.

My printers support PCL5 and PostScript Level 3. PPD is available for each printer model.

When I proof print Tutorial documents at OL Learn with setting Generic PCL for Printer Model, it prints okay. But if I choose Generic PS LEVEL3 (DSC), the my printer shows error below.

ERROR: invalidaccess OFFENDING COMMAND: def
STACK: CFFArial-Bold, 3379, --filestream–, sco, [0.502 0.502 0.502],

It seems the printer has error with Type 2 (Compact Font Format) fonts. Every tutorial document causes my printer error at CFF-font definition.

Question: Are there any method to tell PlanetPress NOT to use Type 2 fonts?

I tried with Generic PS LEVEL2 (DSC), then the printer prints okay. But, I need to 
use printer's specific PPD to utilize printer specific features like stacker finisher
or stapler. If I choose PPD file for Printer Model, the printer again shows same error. 

I want PlanetPress NOT to use Type 2 fonts while I am using printer’s PPD.