OL Learn

Concatenation string

I have a 3 line data selection, using

<br />

as the concatenation string.
When I use the use the data in my template, the

<br>
is displayed rather than interpreted as a new line. I’ve tried every variation I can think of, but nothing works.


Probably something ridiculously simple…

Is your field being displayed inside of a <PRE> element? That element displays its contents as-is, with no interpretation of the embedded HTML tokens.

No , it is inside a div, and Connect has added a span over which I have no control.
Here is the code from the source tab -

      <div anchor="page_media_0"
    style="position: absolute; overflow: hidden; box-sizing: border-box; line-height: 11pt; font-family: &quot;Courier New&quot;; font-size: 12pt; width: 1035px; height: 69px; top: 26.9833px; left: -0.01666670000000181px;" offset-x="37.783332537060545" offset-y="64.78329923706055">
          @ColumnHeadings@
    </div>

from the html preview

 <div class="ol_drag_element" style='left: -0.01px; top: 26.98px; width: 1035px; height: 69px; line-height: 11pt; overflow: hidden; font-family: "Courier New"; font-size: 12pt; position: absolute; box-sizing: border-box;' offset-y="64.78329923706055" offset-x="37.783332537060545" anchor="page_media_0">
     <span>Title                              Full   Odds    Total    Label    Bun    Bench  Bench   &lt;br/&gt;Issue                              Buns                     Siz     Siz    Full    Odds   &lt;br/&gt;                                                                           Buns           </span><br> 
 </div>

The only other thing I can think of is that your Script is set to insert the contents of the field as Text instead of as HTML:
image

Phil
Thank you very much, you have solved the riddle!

:smiley:

1 Like

The resemblance is uncanny.