OL Learn

Controlling detail table overflowing

I have a duplex section which contains a detail table on the first page. The detail table can overflow onto other pages.
There is a requirement for a terms and conditions pdf to go on the back of the first sheet.

How can I prevent the detail table from overflowing into the terms and conditions page and only carry on overflowing from the third page?

Hi ssime,

Right click your Section and select Sheet Configuration, change “Allow content on” from “All Sides” to “Front Only”. Also depending on your requirements you might want to untick “Same for all positions” and apply certain Master pages or Medias to Single Sheet records and records that could have First/Middle and Last sheets.

Regards,
S

@Sharne, Thank you so much for your input. It sounds like it should work but I’m probably doing something wrong yet again :grimacing:

Do you have a basic example showing how to set this up. I only need the terms pdf as the second page and on the back of the first sheet. Some records will have one sheet other multiple sheets.

Thank you so much for your help.
Steve.

Hi

Just take a look at this sample: https://learn.objectiflune.com/howto/t-and-c-on-the-back-of-the-first-page-only/

1 Like

Hi ssime,

You can try Sergios how to link. (I actually forgot about the how to section) or here is a sample mapper and template. LINK. (Close/ignore dropbox prompt to signup and click download button to the top right) Just note the Sheet Configuration settings used. It can be a little confusing at first, so play around with those settings. Also note the Header/Footer margins added to the master page table (in properties) that forces the table onto a specific portion of the section.

EDIT: If you don’t want the blank page at the end just tick “Omit empty back side for Last or Single sheet” checkbox under the duplex checkbox in sheet configuration.)

Hope that helps.

Regards,
S

1 Like

Thank you guys. I have now got this working.

I’m following this with interest, and don’t quite understand the setting of allowing content only on one side. The description reads:

Allow content on: Selects on which face of the sheet content is allowed.
If Front only or Back only is selected, the page acts as a Simplex page even though Duplex printing is enabled. The other page may contain a Master Page, but no contents will be printed on it. As such it does not count in the Content Page Number and Content Page Count markers which can be inserted via the Insert menu (see Page numbers ).

But in the output, the first page definitely isn’t Simplex, and it DOES have “content” on it, the Terms of Conditions.

Can someone provide a better description of this setting and what it is actually doing?

I’ve always understood it as Allow Content spilling from the front of the page to the back of the page or any page thereafter. (aka All Sides) Disallowing content, i.e. in this posts case Front Only, forces any overflow to skip the back page of Single Sheet & First Sheet.

If you put variable data on the Master Page Terms it will still show that Content because it does not overflow from Section 1 front.

Perhaps a OL employee can clarify? @hamelj @Erik

Regards,
S

The “Allow content on” option effects the main content flow e.g. the content of the of a section for Duplex sections. Example: when setting the option to “Front only” for the First/Single sheet of an invoice template a long detail table will flow from the front of the First sheet to the front of a subsequent sheet.

The back of the First sheet may still show content from the master page or a media image. This also means you can still use scripts to personalise elements on the master page as this is not part of the “content” in the main flow.

Hope this helps,

Erik

PS. A PDF DataMapper background is also considered content and will follow the “Allow content on” setting.

PS. Note there is a difference between “Content Page Number” and “Page Number” (these are separate markers)