Upland OL User community

Crash on Output

Hi all I seem to be getting the following Plugin Failure does anyone know what this might mean so I can attempt to sort it out?

15:38:50.137 [0111] W3001 : Error while executing plugin: HTTP/1.1 500 LoggedApplicationException: There was an error running the output creation process caused by NullPointerException: (SRV000042)
15:38:50.137 [0111] Create Output: W1603 : Plugin failed - 15:38:50 (elapsed time: 00:00:00.082)

it creates an output but does not fill it with anything and makes a corrupt PDF

Maybe the output do not get any records. Maybe there is a filter in your jobpresets and the result is 0 records?

Please provide some more informations about your process.

there are certainly records, and the data mapper part passes, This is happening on layouts in the workflow that have previously worked,

is there a way I can debug the process to see if records have really mapped properly and there are records to be parsed?

Check whether the metadata contains any data after executing each individual OL Connect Workflow plugin in Debug modus until you’ve reached the Create Output Workflow plugin. Checking the metadata can be done by going to: Workflow Configuration application > Debug tab > Data section > View Metadata button


there does not seem to be any of the expected data, I think this might mean although my data mapper section has completed successfully it is not actually parsing the data required

Have you tried opening the data related to the issue directly in the Connect Designer?

yes if I use the layout and the datamapper directly in designer, with the data file loaded in as sample data, then I can print a PDF document perfectly fine,

trying to use it with the workflow, i just get the above nullpointer issue, if I try to push the datamapper I have in designer to workflow everything is fine, but if I try to push the layout to workflow then the designer crashes with a similar null pointer issue:

[2023-08-25 10:37:18,627] ERROR [main] com.objectiflune.contentcreation.html.mergeengine.impl.a.raiseError(HtmlMergeCoreUtils.java) Name is null.
java.lang.NullPointerException: Name is null

getting thoroughly vexed, as i’m having to manually provide documents for staff members that would all normally be automated.

Message me in private, I’ll give you my email address so you can share your Template and Datamapper so I can look into it.

Feel free to remove sensitive information. As long as it is reproducible.

unfortunately sharing the layout is definitely a no go, there is so much client related artwork and information, even in just the names of the sections involved, it would 100% breach 27001 policies.

I’ve noticed that just prior to this crash of the designer though its has failed to getpagestride & getpageseperation if that might be the reason why the nullpointer is occuring:

[2023-08-25 10:37:18,619] ERROR [main] com.objectiflune.layoutengine.html.pagination.PaginationProvider.run(j.java) getPageStride gave no result, but pageCount=null
[2023-08-25 10:37:18,620] ERROR [main] com.objectiflune.layoutengine.html.pagination.PaginationProvider.run(j.java) getPageSeparation gave no result, but pageCount=null

To help you properly we would need to see the Template and reproduce the issue. I suggest you open a technical support ticket through our website.

I’ve attempted to sign up to upland support a few days ago, I am still awaiting a response to that.

I’m trying to figure out a way to clear the template out of any client info, though the template involved is a fairly complex one, as it is used for a lot of digital proofing of client products.

Hello @LukeDC,

Do you already have access to our Community website?

no i have requested for access but no mail has been received yet

I’m sorry to hear that. I see in our system that you should have received an email about this a few days ago [internal reference: #1352994].