OL Learn

Create Email Content - Authentication Failed

Hi,

I’m trying to send an email using the Create Email Content process on the workflow but I get an error message. (See below)

[0014] W3001 : Error while executing plugin: HTTP/1.1 500 ApplicationException: Authentication failed.
ApplicationException: Authentication failed.

  • [0014] Create Email Content: W1603 : Plugin failed - 11:34:05 (elapsed time: 00:00:09:853)*

I have tried to send a test email on the designer using our mail host and it works fine. However, when I set it up on the workflow and input the details on the “Email Info” I get an error like the above.

Can someone please help? Thank you so much!

That authentication failed message looks more like it’s failing to authenticate to the Connect Server itself. Are you having trouble with any of the other Connect plugins? For instance, you’ve probably got a datamapper happening before this, no? Does it execute correctly?

In general, you’d want your Workflow preferences to be configured with your Connect username and Password as shown below.

Capture

These should match whatever you’ve defined in the Connect Server Configuration under Connections > Security.

Capture

Note: These do not correspond to a Windows username. They are entirely separate and are used for authenticating through the Connect Server’s REST API. All Connect based plugins in the workflow will default to whatever is defined under Preferences > Behavior > OL Connect > Server Connection Settings, unless override credentials are provided through the OL Connect Proxy tab on the plugin itself.

If you don’t know what the password is, you can change it first in the Connect Server Configuration, then apply the change to both Workflow and all Designer clients. For Designer, you’ll go to Window > Preferences > Print > General.

For the default password, please open a support ticket and we’ll provide it.

Hi,

I do have datamapper before the Create Email Content process and it works fine.

I don’t have any problems with other Connect plugins(I can also use the “Send Email” plug-in without any errors) .

All the details (Server address,port,user name, password) on my Connect Server Configuration are the same with my Workflow and Designer Preferences. I also input our SMTP mail host on the Email Creation Settings and still get the same error message.

tempsnip