OL Learn

Create Print Content - Socket Error # 10060

Hello,

I’m experiencing error from the topic. The error is not consistent. Sometimes job completes successfully when I’m they processing same data again. What can cause this problem?

ERROR: 11:58:21.206 [0004] W3001 : Error while executing plugin: Socket Error # 10060
Connection timed out
ERROR: 11:58:21.206 [0004] 1: in1|571025480.pdf|Create Print Content
INFO : 11:58:21.206 [0004] Store Message “in1|571025480.pdf|Create Print Content” in variable “%8”
ERROR: 11:58:21.206 [0004] 印刷コンテント作成(Create print contents): W1603 : Plugin failed - 11:58:21 (elapsed time: 00:00:21.190)

Hello,
as this issue is random I suggest first to check the anti-virus.
Verify the exclusions on this link: https://help.objectiflune.com/en/pres-connect-user-guide/2021.1/#Installation/Antivirus_Exclusions.htm

It could be also memory issue or something else. You could find more information in Connect logs available here:
C:\Users\xxx\Connect\logs\Mergeengine
and C:\Users\xxx\Connect\logs\Server

@Yann thank you. Actualy i’m more concerned about memory problem. So apparently there is i7-6700 processor on the server and in server configuration Engines are configured like this:

DataMapper 3 engines 4096MB
Mergeengine 12 engines 4096MB
Weaver engine 12 engines 4096MB

Could that be the issue?

Hi @tomtom,

Can you let us know please how many RAM there is available on your environment? Because please note that the Connect Engines can make use up to a maximum of 110,000 MB (110 GB) of Memory (27 * 4,096 MB).

Not sure how much is available. Total RAM is 32GB

Can you recommend some settings? Workflow is using 3 self replicating processes that each is doing “Execute data mapping” and “Create print content”

I would like to suggest to start with the default settings. If that’s not enough–if for example the Memory usage of the Data Mapper Engines is always at it’s maximum–increase the Memory to 1,024 MB and if required AND if there is still enough free Memory available increase it to 2,048 MB or 3,072 MB. And in the meanwhile you can also test if increasing the number of engines will improve the performance.

Please make sure that the total amount of the Memory settings of the Connect Engines is NOT larger than the available free RAM. And depending on the other applications active on the specific environment: please make sure that the total amount of the Memory settings is 2 or 4 GB less than the available free RAM.

Please also include the number of engines in your calculations, like:

  • DataMapper Engines: 1, 1,024 MB each (1 * 1,024 MB)
  • Merge Engines: 2, 1,024 MB each (2 * 1,024 MB)
  • Weaver Engines: 1, 1,024 MB each (1 * 1,024 MB)

Total: 4,096 MB (1,024 MB + 2,048 MB + 1,024 MB)

1 Like

I think it’s unreasonable to expect users to calculate and, through trial and error, adjust memory and performance settings. This “let jobs fail until you get it right” approach to what should be production-quality software is a major weakness in the Connect architecture.