Upland OL User community

Data mapper failure error

Hi all,

Scratching my head try to decipher the below error, job fails at data mapping stage, has only started appearing since Workflow update:

W3001 : Error while executing plugin: {“error”:{“status”:500,“message”:“An unspecified error occurred which was caused by NullPointerException: Cannot invoke “org.pac4j.sql.profile.DbProfile.getAttribute(String)” because “” is null (SRV000001)”,“parameter”:""}}

Would someone be able to point me in the right direction.


Have you tried opening the data mapping configuration with the Designer? That should give you a better idea of where to look.

Thanks for the reply @Phil.

We’re running a version behind on desktop so I tried the design/ mapper on server (designer is up to date on server). Both designer and data mapper loaded OK with no issues. Updated the design/ data mapper configurations on server using up to date designer/ mapper and got the same error message.

It’s only appeared after server update.

Have you re-sent the data mapping config to your Workflow Server?

If you did, and you are still running into issues, I would advise you to open a ticket with our Support team, I’m pretty sure they’ll be able to figure it out in no time.

Have you tried with the exact data which you get an error on your Server while in the Design tool?

Thanks @Phil, @hamelj. Appreciate your input.

Have resent data mapper config. and tried exact data in design tool. No joy.

Will put a ticket in with support.

Could it be that you have runtime parameters you forgot to fill up in your Execute Data Mapping plugin in Workflow?
It wouldn’t error out in the Desing toll as most likely you have setup a default value.

Thanks @hamelj. Don’t have any runtime parameters on the job.

Cracked it in the end. Permissions issue on server config.

Appreciate all your input and prompt responses. Job running fine now.