Decreased in performance after upgrading 2022 to 2023.1


We have just recently upgraded Connect Server from 2022 to 2023.1. With same settings intact from previous version under Server Configuration.

I thought to run a process that has consistently completed around 1 hour mark in Connect Workflow.

I made sure to the same settings applied to the new install.
Now the same process , same data that we previously run , now takes twice as much or longer 2-3 hours mark.

What would be the obvious cause of this?

Below are what Ive tried and information during the installation

  • There were no big issue in regards to the installation aside from after the upgrade and opened server configuration settings. An error popped up stating “some invalid values in the page”. I just ignored this and okayed. This error kept on popping up.

So I though to repair the installation/reinstalled once again and the error disappeared.

  • The previous template that was used was created from 2022, so I thought to convert the template to 2023 as well. As there might be an overhead between the versions. Converted and sent to workflow.

  • So again I played around with the engine, and put it back to default. Run the process again and still no changes.

  • Have run same process multiple times in a day with no other process running.

  • In the log below (bottom to top order)
    The time between these 2 task took 48 minutes to run (after the upgrade)

    Previously (before the upgrade) it only took around 14-15 minutes to complete

Now I cant really see anything obvious that would suddenly decrease the performance. I would expect it to be same or better after the upgrade. Same hardware spec, same settings… decrease performance all of a sudden?

Any insight would be helpful.

Thank you
Kind regards,


I ran the process in debug, the data mapper seems to be stalling even the log says it has completed:
Refer to the highlighted timestamp, in the log and my pc time.

Update: After 20 minutes , it finally able to go to the next task. Im guessing this could be one of the reason why it takes so long too.

This has been resolved by doing a full clean reinstall. (Also removing user data)


1 Like