OL Learn

Display Chinese word in data

May I know how can I display Chinese word in datamapper and template? Thanks
image

Hi @ceci_cheung,

Can you let us know please what kind of file you are using for your Data Mapping Configuration file, is that for example a PDF, TXT or XML file?

Hi @Marten,
For you reference, the input files is CSV and the output files is pdf.

Hi @ceci_cheung,

Do you know in what kind of encoding the CSV file is? You can check this by opening the CSV file in for example Notepad. In the bottom-right of this application you can see the encoding of the file you’ve opened in Notepad.

Hi @Marten
Yes, the encoding is utf-8. I can see the Chinese by opening the data by notepad.
Thanks

Have you already checked if changed the encoding of your Data Mapping Configuration to UTF-8 solve the issue you’re currently facing? You can change the encoding via: Settings pane > Input Data > Encoding

screenshot-20211018

@Marten,
Yes, even if i chose UTF-8 for encoding. Chinese wordings still cannot be displayed.

Hi @ceci_cheung,

Can you please share the anonymized CSV file? Because then I can have a look for you why the text looks still wrong.

Hi @Marten
Yes sure. Attached the CSV file for your reference. 1.2.392.200036.9116.6.33.10532439.1041.20211007024348305.2.6.csv (2.1 KB)

Hi ceci_cheung
It looks fine when i use UTF-8 Encoding in Datamapper with your csv file

I used to have same issue, and changing Encoding to UTF-8 absolutely did fix that issue before.

Have you try to install Chinese(Traditional and simply Chinese) in your system?

@CainZ
That’s so wired that i have installed Chinese in my system already.
But I think that’s my PC settings issue since you can display Chinese word with my data.