OL Learn

Error caused by nulll

Does anyone have ideas why I get error below?

W3001:eRROR WHILE EXCUTING PUGIN: http/1.1 500 internal server error LoggedApplicationException: There was an error running the content creation process caused by null

All in One: W1603: Plugin falied 116:31:24 (elapsed time:00:00:00:570)

Data mapper and templates show no error and was able to proof print from Connect Design. When the template and data mapper load into workflow and the error accord.

Thanks.Katie

Can you check your data file into a text editor like Notepadd++ and show all characters to see if you have any NULL characters in it?

The NULL Workflow error could also be a variable/field in your template that is requiring a value from Workflow. Doing that by any chance?

Did you try in your datamapper the exact same file that is causing the error in Workflow?

Just in case somebody else gets this error, the reason why you don’t get the error in the print preview is that the cause of the error is beyond the 200 records used by the datamapper.
As for the error, in case the data is xml, it could be a special character like the ‘&’ or a ‘<’ that appears in some field. To fix it you need to escape it with & or >

Hi,
I’m having the same error and I’m using a field from Workflow and print its value in my template. I’ve tried to remove that on the template but I’m still getting the same error.

Help on this please.

Hi Stephanie,

If you remove this field from the datamapper and template would the error persist?
Does the error occur if you test with a 1 record data file?
Load a small data file in the datamapper and look for any error in the first object in the Steps pane.
Other things to note, verify that you have followed the right steps for creating the variable.
Below is a guideline I have copied from another ticket. I hope that would help.

This simple 2-step trick will let you get any Local and Global variables from PlanetPress Workflow
into your record, for use in your template.

There’s a few ways in this it becomes super useful:

  • Using global variables defining global URLs and paths for links and resources
  • Loading different sections or snippets using a variable set in the workflow
  • Controlling object positions from Workflow (such as address block position depending on the printer)

Step 1 - Define the variable in the Preprocessor Step

Though variables are “passed on” to the data mapping task automatically, you need to declare them in
your data mapping configuration for them to be useable. To do this, simply click on the Preprocessor
step in the Steps pane, then look at the Properties section. Click Add Property. In the property’s
definition, you need 3 important things.

  • First the name, which must correspond to the name of the variable in Workflow. Both local and global
    variables are called the same way, with their name as it’s displayed in the Resources pane of Workflow.
    Local variables have priority so if you have a local and global variable named the same, the local one
    is used.
  • Second, the scope which has to be set to Automation.
  • Third, the default value, which is useful to test your data mapping and template with just a static
    value that’s replaced at runtime.

Step 2: Add the value to your record

Adding a property to your record is done through a very simple script. Here’s how you do it:

1- Open an Extraction step that is not within a loop, or create a new one.
2- Click the Add Javascript Field button next to the Field List drop-down.
3- In the Expression, type in the appropriate variable name preceded by automation.variables. , so if
you have in automation property declared as my_var , you’d get automation.variables.my_var;
4- Rename the field in the Order and Rename Fields dialog.
5- Save the configuration

From this point on, the Template that uses this data mapping configuration has access to the variable
added to the data model. Of course, you will only see the default value at this point, the actual value
will only be available once the data mapping configuration and template run in Workflow.

Job Infos, no data mapping required:
So, one last thing to note: It’s wholly possible to use JobInfos without having a data mapping
configuration loaded. This is only true for Web contexts, when using 0 as the Record ID in the Create
Email Contents task. However, these can only be used in Scripts, using automation.jobInfos.JobInfo1 to
automation.jobInfos.JobInfo9.

Thanks Farid for your help. :slight_smile:

This has been resolved already.