OL Learn

Error with Create Output plug-in

Hi,

When I ran the workflow to generate the property tax notices (about 100k records) last night, I got the following error message with the Create Output step (sending the pdf files to Xerox):


W3001 : Error while executing plugin: HTTP/1.1 500 Internal Server Error LoggedApplicationException: There was an error running the output creation process caused by ApplicationException: Error writing buffer to output. (SRV000042)

Could be a memory issue or a disk space issue related?

I checked this with our system administrator and found the RAM currently is 16 GB and the working disk space is 7GB. The number of Merge engine is 3 and the number of weaver engine is 2.

Any comment or suggestion is much appreciated.

John

As it is stated in our documentation, the disk space requirement is 10 gb (20 gb recommended). Again that would be better troubleshooted via a technical support ticket.

To help you properly we would need to see the Template and reproduce the issue. I suggest you open a technical support call at 1-866-348-5863 or through our website.

Try changing the Weaver high memory limit (-Xmx flag) to 2 GB or 3GB or 4GB or more (i.e. -Xmx2g or -Xmx3g or -Xmx4g or more) from the following file:C:\Program Files\Objectif Lune\OL Connect\weaverengine\Weaverengine.ini The default value of 640 MB is simply too low for this kind of job.

In addition, if you have recently upgraded to 1.8, it’s possible that the memory settings on the merge and weaver engines have reverted to their defaults.

It’s also fair to say that your system is running low on disk space. I would make sure to have at least 20GB of free disk space and if possible increase RAM on the system as well. The more RAM and CPU cores, the more engines you can activate and the faster the soultion will run.

Please take a look at this link for more information:
http://help.objectiflune.com/en/planetpress-connect-user-guide/1.8/#Installation/Performance_Considerations.htm

Once you increase RAM on Weaver engines, remember to restart both the OLConnect_MySQl and OLConnect_Server services.

Thanks Hamelj. I tried the workflow last night about 20 GB disk space and I got the same error message: run out of memory.

I will try to increase the RAM for Weaver Engine first as Rod suggested tonight. If the issue insists, I will have to create a support ticket.

There is an problem though to have you guys look at the template and data mapper, because you need about 100k data to reproduce the issue. I am not sure if we can provide you with the real confidential data.

John

Yes, Rod, it makes sense to us to increase the RAM from 640m to 2g for the Weaver engine and have another run tonight. Will let you know the result.

Thanks a lot !

John

Has increasing memory on the weaver engine resolved the issue at you rend?

Hi Rod,

I noticed the workflow speeded up after we added one more Merge Engine and one more Weaver Engine, and increasing the RAM to 2GB.

However, we still got the same error.

W3001 : Error while executing plugin: Out of memory while expanding memory stream

Create Output: W1603 : Plugin failed - 06:11:46 (elapsed time: 01:48:37:951)

Jean-Cédric Hamel from Objectif lune is helping us to repair the workflow. At first we need to figure out how big the PDF is. Per Jean-Cédric, the workflow software as a windows 32 bit application can handle only a pdf file with a less then 2 GB sized pdf file. We ran a simplified process last night to identify the size and found out it is about 1.454 GB. Jean-Cédric and I modified the process a bit and will run it again tonight. If it is working, we need to add another branch to the workflow to send the grouped pdf files to Xerox. So we try out the process step by step until we solve the issue.

Thanks for checking.

Have a nice day!

John

I have seen that error before and the way I got around it is by having Connect move the file to disk with (Create Output) rather than Workflow(with Send to Folder).

This means your output folder will need to be configured in the Connect Output preset. The Create Output task in Workflow should then be run with the “As defined by Output Preset” option.