OL Learn

External Program ".BAT" - Works in Debug, Not when Scheduled

So the title says it all. I have an external .bat file that runs Cygnus from the command prompt. If I run the workflow process in Debug, the .bat runs, opens Cygnus, processes our .csv file and closes as expected.

If I schedule the task to run, it does everything - the bat file runs (according to the log output), however Cygnus produces no output. I have tried “Run minimized” and not and neither makes a difference.

Any ideas?

Main idea that comes up is a right issue. Check if Cygnus can be called from a service.

When you run in debug, you have the credentials of the user under which you are currently logged in.
When Worklow runs it, it uses the credentials of the Worklfow services. Even if you have set it up to use the same credentials as you are logged in, it is still running as a service and rights will differs.

More specifically, when running as a service, programs do not have an interactive desktop. If the software requires an interactive desktop, then it’s not going to work. You may have to seek some other way to interface with Cygnus.

I have no idea what Cygnus is or what it does, but you could also consider altering the BAT file so that the call to Cygnus uses RUNAS in order to execute it under different credentials.