Upland OL User community

Folder Capture - is it possible to ignore the archive attribute?

We use the Folder Capture plugin to ingest data that a client uploads to us via FTP.

The client uploaded some files that had the Archive attribute set and the Folder Capture step ignored them as it is supposed to behave.

Given that this is an input only folder with no circular downloads (no other Connect process deposits files there) is there a way to have the Folder Capture plugin ignore the archive attribute?

If no, how can we reset the archive attribute o files in a folder using the workflow?

I’ve already checked out this conversation (Folder Capture Use archive attribute) but it is meant for files already “in the pipe” of a workflow process.

Create a process with a File Count input task. If no files are found, it won’t run the process, but if there are any files, then add a External Program task as follows, to reset the attributes on the files:

Obviously, change the value in the “Start in” field to the actual name of your input folder.

1 Like

I’m coming back at the topic because we just found out that CMD doesn’t work with network paths.

If “Start In” is set to a windows share like \my-server\input CMD fails. I’ve tried to google around an answer with no success.

The most relevant I info I found is https://superuser.com/questions/282963/browse-an-unc-path-using-windows-cmd-without-mapping-it-to-a-network-drive#399885, however with the external program plugin I can’t execute multiple consecutive commands as shown in the stack overflow example.

Is there any additional resource worth sharing on the subject?

You can group multiple CMD commands inside a batch file, and then you can call that batch file by specifying its name in the Parameters field of the External Program task.

Re-using the example from above, you could create a file named MyBatch.cmd in the D:\Test\Dummy\ folder. That file would contain something similar to:

@echo off
pushd \\Myserver\MyShare\SomeFolder
attrib +A *.*
popd

In the External Program task’s Parameters setting, you would specify

/c MyBatch.cmd

Adjust, rinse and repeat! :slight_smile: