OL Learn

Folder input : How to use an NFS Share

Hello,

I would like to get the data from an NFS Share but I don’t find the correct syntax and have message like that in the logs :

16:19:57.889 [0001] File move failed : \192.168.1.2\FOLDER-SHARED-NFS\2019-000001.xml
16:20:10.014 [0001] W3011 : Input folder error: A call to an OS function failed

Today I tryed with this syntax :

\192.168.1.2\FOLDER-SHARED-NFS\

Could you please help me ?

Regards,

Make sure that your share is available to services. Remember that the user under which you Configure your Workflow process is different than the one the Workflow services run under. Even if it is the same user, one’s a Desktop version of the user as the other is a service version. Rights might not apply the same to your shared folder.

I don’t believe that PlanetPress Workflow supports the NFS filesystem but saying that, it’s been a while since it has come up so I’m not sure about in the newer Connect Workflow specifically as I have never tried it but in my experience using filesystems, NFS is usually accessed using:

nfs://<hostname>:/<sharename>

So I would drop of the nfs:// and to be specific for your example, try:

192.168.1.2:/FOLDER-SHARED-NFS

Then you can still set your filename mask as usual.

However my guess is that you’d have to map it as a drive in Windows before you can see it - if you do that, make sure it’s mapped for the user account (or service user) running Workflow.

Hello,

Thanks, I tried both but nothing work.
I share your guess, we first have to mount the drive on the system then use it in PP Workflow.
Many thanks.

Best regards,

A syntax like the following has always worked for me (and doesn’t require you to map a drive):

\\192.168.1.2\MySharedFolder\

@Phil - is this for NFS (Unix) shares?

If that is the case, @gengiskhan, it is likely you just need to add the Services for NFS in Add/Remove Features for the Windows OS.

Great, many thanks. it was a windows Share and reinstall the NFS client makes it work with this syntax. Thank you Phil and Jim3108

Oups, I realize that it do not work actually using every syntax mentionned in this thread

\\192.168.1.2\MySharedFolder\
192.168.1.2:/FOLDER-SHARED-NFS

I got these error messages in the console :frowning: