OL Learn

Funky Glyphs (Diamond with Question Mark)

Occasionally, the PlanetPress generated trailer page show these funky glyphs.
The process adds a trailing page with information about the job. The elements with the funky glyphs is data extracted from the PDF.

At first I though this had something to do with a font, but these are being extracted by the data mapper.

image

This only occurs with some PDF files, 1/8th of the sample files.
Any Ideas?

Hi, this could be an issue with the font encoding of the PDF.
You could try to recreate a PDF with Acrobat Distiller, or other tools.
Also did you tried to extract with the lastest Connect version?

The PDF files (%PDF-1.5) are the input data, so I don’t have control over their creation.
Used PPC v2021.2 to extract with and have not tried PPC v2022.1.
I did try saving the PDF with a couple other PDF tools, but without any difference.
It might be related to Acrobat Extended Features, but not exactly sure what these are.
When I open the PDF files (with the funky glyphs) with a viewer, I get a dialog.

What happens if you select and copy the text from the PDF using Acrobat Reader and paste it in Notepad? That’s usually a good rule of thumb to determine whether text can be extracted to start with or not.

It appears to extract from the PDF correctly.

Note that the funky glyphs only seem to appear on the trailer page.
Although using text extracted from the PDF such as the page numbers.

In that case, I would recommend that you open a support case for this so that we can take a closer look at that PDF.