OL Learn

HTTP Does not respond with POST

Hello

I want to submit a file via POST with datafile attached.
With the data, I’ll create a pdf and return it to the HTTP caller.
I created a small process to just return a predefined file and here what’s happening:
If I attach a file to the POST (1st thread) : process does not return the pdf
If I don’t attach a file to the POST (2nd thread): process returns the pdf.
I see that there is “second execution” in this latest thread but I don’t understand why Thread 1 does not return the expected file.

Any idea?

Regards

Olivier

Thread 1
JustReadTest (thread id: 7120) - 08:59:36
08:59:36.950 [0001] First execution: processing file.
08:59:37.077 [0001] File captured : C:\ProgramData\Objectif Lune\PlanetPress Workflow 8\PlanetPress Watch\Spool\1.tmp\job010553ASOEHJM8D62D8F3EE.dat, size: 23555 bytes
08:59:37.077 [0001] Replicating process “JustReadTest”.
08:59:37.077 [0001] Plugin HTTP Server Input completed successfully - 08:59:37 (elapsed time: 00:00:00:127)
08:59:37.079 [0002] Plugin Load External File completed successfully - 08:59:37 (elapsed time: 00:00:00:002)
08:59:37.079 [0003] Deleting file : job010553ASOEHJM8D62D8F3EE.dat, size: 49819 bytes
08:59:37.079 [0003] Plugin Delete completed successfully - 08:59:37 (elapsed time: 00:00:00:000)
JustReadTest (thread id: 7120) complete - 08:59:37 (elapsed time: 00:00:00:129)

Thread 2
JustReadTest (thread id: 7120) - 09:00:45
09:00:45.120 [0001] First execution: processing file.
09:00:45.130 [0001] File captured : C:\ProgramData\Objectif Lune\PlanetPress Workflow 8\PlanetPress Watch\Spool\1.tmp\job010553B3Y9RJHC262D9FE3A.dat, size: 1892 bytes
09:00:45.130 [0001] Replicating process “JustReadTest”.
09:00:45.130 [0001] Plugin HTTP Server Input completed successfully - 09:00:45 (elapsed time: 00:00:00:010)
09:00:45.132 [0002] Plugin Load External File completed successfully - 09:00:45 (elapsed time: 00:00:00:002)
09:00:45.132 [0003] Deleting file : job010553B3Y9RJHC262D9FE3A.dat, size: 49819 bytes
09:00:45.132 [0003] Plugin Delete completed successfully - 09:00:45 (elapsed time: 00:00:00:000)
09:00:45.132 [0003] Second execution.
09:00:45.164 [0003] File sent to HTTP Server : C:\ProgramData\Objectif Lune\PlanetPress Workflow 8\PlanetPress Watch\http\justread\STemp010553B3YCC9I0262D9FE4A.txt, size: 49819 bytes
09:00:45.164 [0003] Plugin response HTTP Server Input completed successfully - 09:00:45 (elapsed time: 00:00:00:044)
JustReadTest (thread id: 7120) complete - 09:00:45 (elapsed time: 00:00:00:045)

Just had answer from support.
I created a branch to generated pdf and in the main branch just load the generated file.
I had also to change HTTP parameters: uncheck the “Loop through each attachment as datafile”.

Worked