OL Learn

HTTP-Response from Workflow wrong encoding

Hello,
I have a workflow process where a HTTP request is received. The request is sent via an HTML page that is utf-8 encoded. Also the form sending via Ajax should be set in utf-8 (contentType: “application/x-www-form-urlencoded; charset=UTF-8”). However, the XML in the workflow process is always encoded in “windows-1252”.
Can anyone explain why this is so? Could it be because PlanetPress Workflow was installed in German?
Is there a way to change the default character encoding in the workflow to UTF-8?

I know that I can handle it manually via the encoding translator plugin. But it would be great to fix it generally.

PS: I have a lot of processes with HTTP-Server-Input (in different projects) which interact dynamically with websites and theres always the same problem.

The HTTP Server input task does not allow you to set the encoding for the request file.
Use the NodeJS Server input task instead. It allows you to switch between the current OS encoding or UTF-8.

Ok, thanks. I will think about using that plugin.

In the past I tried to change all working processes from HTTP-Server-Input to NodeJS-Server-Input and had big problems. The NodeJS service killed himself automatically, directly after starting the service. I found out that the problem comes when I have too many processes in my workflow configuration. It does not matter how many processes use the NodeJS-Server-Input. Only the amount of processes was the problem (als deactivated processes).
I reported it to our local technical support team, but they could not reproduce it properly. So I decided not to use NodeJS-Server-Input for customers who have a lot of processes.
Because of that I am a little afraid about using the plugin.

I have changed all HTTP-Server-Input plugin with NodeJS-Server-Input plugin. Now I have the same problem as described before. Directly after starting the NodeJS Server service, the service stops with the following errors:

2020-07-23T10:28:27.344 ppNode - Error: Unclosed root tag
2020-07-23T10:28:27.350 ppNode - Error loading config file. The configuration provided might not support NodeJS.

It is a workflow configuration where I never tried to use NodeJS. The configuration has a lot of processes (more than 38 processes) and many of them are self-replicating.
After deleting round about 19 processes the service runs with stopping itself with an error.

38 processes is not a lot, so there is something else going on. The first message (Unclosed root tag) hints at some kind of corruption issue with your configuration. I would advise you open a ticket with our Support team so you can provide them with the config file and they can determine what the actual issue is.