Upland OL User community

Installation fails

If I try to install Designer 2022.1.5 installation does not even start.



The setup cannot be started - the setup file may be corrupted or you may have entered the wrong password. If you have downloaded this file, please download a new copy. If the file is password protected, check your password and try again.

What could be the problem here? This happens on a production server as well as on a vm clone.

You must have Admin rights in order to install OL Connect. Please double check your credentials.

If that doesn’t fix it, open a ticket with our Support staff, they should be able to resolve your issue quickly.

I have administrative privileges, also I tried “run as administrator”.
But I pasted the wrong image, that is about the Workflow Installation, that also fails.

The correct screenshot for Designer is:

I already contacted support staff, they are not helpful.

Hi @Xanathon, I am not sure where you have copied or download the installer from, but could you please check – if possible – if the same error message will be shown after recopying or redownloading the installer file.

Hi Xanathon,

We have recently noticed a few antivirus removing components from our installation packages even as they were being downloaded. This could be at play here and I’d recommend making sure to disable it temporarily while you download and install. If disabling is not an option, work with your security people to ensure whitelisting any port, path, URL, exe, so it virtually becomes irrelevant while you set up the software.

Another potential issue could be the right to install interactive services is set to “false” in your registry. However, while this would impact your ability to install the services, I wouldn’t expect this specific error at that specific step of your installation to be thrown by that setting. This is just another item to keep in mind.

You mentioned you contacted support with this and didn’t get the expected help. Can you provide a ticket ID in reference to this? We take great pride in the quality of the support we provide, so we must learn from this situation if it did not meet your expectations, and hopefully we can improve your situation in the process of our investigation.

Thanks. Regards,

It is not an antivirus problem and it is not a broken file, I downloaded the setup file multiple times.

But I can tell you what the problem was, and that should be fixed by your devs for the future.

We have a folder where we collect older versions of the workflow and designer installers, if there ever arises the need to go back to an older version. This is a production environment where thousands of packages are sent on a daily basis and that need to be running. This becomes more and more problematic with all the recent installer problems that came with Connect. Suite 7 could just be updated, Connect updates fail every time, especially since this recent “new installer” was rolled out in a non production-ready state.

All installers always have the same filename, regardless of the version. So to be able to differentiate them we rename them. In this case I added “2022_1_5” to the end of the installer filename before the file extension.

And that leads to the above problem. It looks like some kind of CRC check is done not only on the file content, but also on the filename, and if that is changed, installer refuses to install with very misleading error messages. If I redownload and keep the filename, the installer starts (I then get other problems with MariaDB because you software does not recognize if mySQL is already running on the system on the same port, but that is another ticket that has never been solved by support and I just use another port for MariaDB).

I strongly advise to change future installer filenames to include the version number.

Ticket number is 1161894

Hi Xanathon,

Thanks for the information. Can you provide the ticket ID as well for the DB port issue that was never solved?

Thanks. Regards,

Hello Xanathon,
Sorry that you feel that our Support team was not helpful.
I will involve our EMEA Support Manager on this one in efforts to resolve this issue.
This will likely be handled in the support ticket.

Cosimo Iacovella

Hello @cosimo_iacovella

thank you for your intervention. Frankly: You should skim through the cases of the last months. Some of them were never solved and we gave up frustrated. Other ones never got solutions, again other confirmed bugs were promised to be fixed in “future” versions, but we never get any feedback at all if they actually ARE fixed in new versions.

I already have invested over one and a half days trying to do something that should be as simple as installing new versions (and it looks like I will have to spend some more days on that), but since moving from Suite to Connect updates became something that can only be called a nightmare.

In addition to that the immensly important workflow that runs all processes (and unbelievably is a 32bit application in 2022 with the memory problems resulting from it) became more and more unstable since the move from Suite to Connect instead getting better as promised. We have already started to migrate processes away from Planetpress Workflow to another, modern application.


Hi Xanathon,
Alex has attempted to reach out to you today to help you. Please reach out to him at your earliest convenience.
We have already escalated the installer issue you’ve reported with our R&D.
It is important to continue to work with our support team.

Cosimo Iacovella


Since we changed from Suite 7 to Connect, Updates became a nightmare.

Your support tells us we have to test the updates in a clone of our productive server. We do that. Both updates (Workflow and Designer) fail. Trying to resolve that and communicating with support (tediously via email) takes days (in addition to our normal workload). Plus the proposed way of testing by installing and running would lead to problems since the license will be voided if we actually start the installation for testing on the clone, because then the services would run two times. But we get that information only after we ask for it (out of bad experiences with backup systems in the past), not proactive by support. When I say to support it would be good to get a test license for these problems that were created by Objectif Lune, support answers we will have to pay for such a test license. And that after Objectif Lune created all these installation problems, updates of Suite 7 Workflow and Designer worked without any problems whatsoever.

We were forced to update the licenses to Connect because Suite did no longer get bugfixes (and showed it’s age) and now instead of the new, improved software we were promised we are flooded with problems and bugs, costing us additional days.

I hope you understand how highly frustrating and dissatisfying this is from a customer’s point of view.