OL Learn

Issues with a TIF background

I’m working on a project that will require adding a TIF ‘security pantograph’ image to the background of a print context form. (Think the “VOID” background image of checks when copied)

To start with some LPI printer testing (to see how the printer engine responds to the pantograph printed from Connect) I’d like to start with a simple form that prints just the background. However when importing the TIF Connect tells me that the image is an unsupported file type and gives a big red X in the Designer if I drop it on to a master page (see screenshot below). The TIF should be the full 8.5 X 11 page size.

It’s difficult to determine what exactly is causing the issue.

The TIF samples can be downloaded from here:
http://www.amgrafonline.com/voidmaker/presstest/vm_pt_download.html

Particularly any of these:
http://www.amgrafonline.com/voidmaker/presstest/PressTest_100_600.zip
http://www.amgrafonline.com/voidmaker/presstest/PressTest_120_600.zip
http://www.amgrafonline.com/voidmaker/presstest/PressTest_133_600.zip

Hi Nate,

We are aware of this problem, it is related to the resolution of the image. The workaround is to save the images in PDF format, this way the preview is handled differently. We hope to resolve this in a future version.

Sorry for the inconvenience,

Erik

Erik,

I’ll try again, but in testing the TIF conversion to PDF, it didn’t work because it “activates” the security pattern. I think that happens because its being rendered twice; once into PDF and then again at the print engine (which is essentially creating a copy of the original which is what the pattern is supposed to prevent).

Other suggestions? Any settings we can tweak somewhere?

Thanks!

Nate,

Which software did you use to convert? Sounds like there are some conversion settings in play to optimize the image. Did you try opening it in Adobe Photoshop, choose Save As. Select the Photoshop PDF format and disable the Compression settings (e.g. Do Not Downsample)?

Erik

The Amgraf void pantograph are supplied as series of pre-screened 1-bit TIFF images of varying density versions. The Void Pantogragh can be in any lossless format such as TIFF, BMP, PNG and possibly PDF (really depends on how it’s done). It is very important that there is no loss (lossless) in the conversion to another image format for the copy protect feature to work.

The typical size of plain paper prescriptions is 8.5 x 11 and at 600 dpi a 8.5 x 11 document would be 5100 x 6600. It appears that the image rendering in 2018.2 does not accept TIFF, BMP or PNG file that are 600dpi and 5100 x 6600 in size. That leaves PDF as the only option, but most editors that produce PDF files appear to help out by either scaling or compressing the image which results in destroying the copy protect features.

Hello Uomo,

Thanks for adding this information. Agree, today PDF is the only option. Can you confirm that saving the image from Adobe Photoshop in PDF format works when the Compression settings are disabled? I could supply a test file if needed (along with PDF output generated by Connect with the sample image as background image).

Let me know,

Erik

Erik,
I don’t have Photoshop readily available so if you could supply the converted file for testing that would be great. I was using the Tracker Software PDF engine to do the conversion.

I do not have Adobe Photoshop.
I tried using Irfan View and Nuance Power PDF.

If you could convert one of the tiffs below that would be great.

http://www.amgrafonline.com/voidmaker/presstest/PressTest_100_600.zip
http://www.amgrafonline.com/voidmaker/presstest/PressTest_120_600.zip
http://www.amgrafonline.com/voidmaker/presstest/PressTest_133_600.zip

Here you go:
PressTest_100_600.pdf
PressTest_120_600.pdf
PressTest_133_600.pdf

The images are saved from Adobe Photoshop.
Erik

Much Appreciated!

I will have access to a printer on Friday, so I will test the PDF versions of the Pantograph to see if the copy protect functionality still works.

The copy protect feature of the PDF version of the pantograph appears to work on a Multi-Function Laser Printer with Postscript. I didn’t think to test it to a PCL printer. The page in the back is the original print and the page in the front is the photocopy.

Pantograph_TestResults-SM

The best option is restoring the ability to use the large format tiff file, but the PDF version appears to be a workaround until then.

Glad things work when using the PDF. Agree that we need to fix this. Thanks for the headsup.

Let’s assume that the Input Data is Postscript that is converted to a PDF using Workflow. The background of the resulting appears to be transparent. I need to have the Pantograph image to be a static background and the RESOURCE_PDF to be in front of the Pantograph. Is there a way to accomplish this? I’ve played around with Control scripts but can’t seem to get it correct.

var activeSection = merge.template.contexts.PRINT.sections[‘Section 1’];
activeSection.background.url = ‘images/OLPressTest_120_600DPI.pdf’;
activeSection.background.source = BackgroundResource.RESOURCE_PDF;
activeSection.background.position = MediaPosition.FIT_TO_MEDIA;

What about using it as a stationery image on the media? In that case you need to print virtual stationery when generating output. Alternatively put the image on the master page.

Set the Pantograph image on Master and set Print Section 1 background to From PDF DataMapper input. Preview displays the Pantograph and added elements, but not the PDF input data.

Set the Pantograph as Virtual Stationary and preview does display both images. I need to verify that the copy protect security features still works, but it looks good otherwise. Are their any ramifications to using Virtual Stationary?

Background Info: With PlanetPress Suite v7 there is a setting for transparency. When the data is a PDF and the Pantograph is a TIF, I could set the Pantograph as transparent and place this layer on top of the PDF background. In PlanetPress Suite v7 if the Pantograph is a PDF this transparency setting does not work so I suspect that the PDF Pantograph is not transparent.

Question: With PlanetPress Connect using the Pantograph as the virtual stationary. The data is a PDF file and does not have a transparent background so it covers up the Pantograph. The Pantograph has to be a PDF for now due to the TIFF issue. When you converted the Pantograph test pages for me earlier, was there an option to preserve transparency in Photoshop?

If there is the option to preserve the transparency, then this next question is relevant. I believe that Virtual Stationary would be out because I don’t think you can put the data from the data mapper there. I would need to be able to place both PDF files on top of each other with the data mapper PDF file first and the static Pantograph on top. Do you have ideas on this?