OL Learn

LPR Failed to send print file command

Hi,

Before I go to far ripping my hair out, I was wondering if anyone could advise the likely cause of the following error? LPR Failed to send print file command

We have several successful print jobs which processed today, however this one job is failing to print correctly. Thoughts? The printer logs do not receive this print job at all.

We have already:

  • Restarted the workflow service
  • Restarted the LPR client service
  • Restarted the printer and printer controller
  • Reviewed the printer logs (nothing reported)

Thanks in advance.

Ian

DEBUG: 09:35:22.363 [0140] Starting plugin Send To Folder - 9:35:22 AM
DEBUG: 09:35:22.363 [0140] Path: %{global.baseDir}\ARCHIVE\BATCH
DEBUG: 09:35:22.363 [0140] Parsed path: C:\BSV\ARCHIVE\BATCH
DEBUG: 09:35:22.363 [0140] Filename: %{batchNumber}_%{type}.pdf
DEBUG: 09:35:22.363 [0140] Parsed filename: 79087040_RESIDUE.pdf
INFO : 09:35:22.368 [0140] File sent : C:\BSV\ARCHIVE\BATCH\79087040_RESIDUE.pdf, size: 6331937 bytes
INFO : 09:35:22.368 [0140] Plugin Send To Folder completed successfully - 9:35:22 AM (elapsed time: 00:00:00.005)

DEBUG: 09:35:22.370 [0141] Starting plugin Create Output - 9:35:22 AM
DEBUG: 09:35:22.400 [0141] Using cached config file (id = 1035770552).
DEBUG: 09:35:22.400 [0141] Starting output creation operation...
ERROR: 09:38:40.955 [0141] W3001 : Error while executing plugin: HTTP/1.1 500 LoggedApplicationException: There was an error running the output creation process caused by IOException: LPR Failed to send print file command (PNR000314) (SRV000042)
ERROR: 09:38:40.956 [0141] 1: 52445523_RESIDUE
ERROR: 09:38:40.956 [0141] Create Output: W1603 : Plugin failed - 9:38:40 AM (elapsed time: 00:03:18.585)

INFO : 09:38:41.022 [0141] File sent to error bin process ERROR
DEBUG: 09:38:41.023 [0141] W1602 : Stopping execution of process
WPROC: BATCH Send to Printer (thread id: 6164) complete - 9:38:41 AM (elapsed time: 00:22:02.442)

We also receive an event in the Windows Event Log which reads as follows:

The description for Event ID 1 from source PPWatch8 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

52445523_RESIDUE

Hi @iwest,

Please check if the Weaver Engine log files does contain any detail information about the β€œLPR Failed to send print file command” error message. These log files are stored at the following location:

%USERPROFILE%\Connect\logs\Weaverengine\

Please check if you are also getting an error by executing the Create Output Workflow plugin when you send the same job to a different printer queue.

Whilst the Weaver engine logs were not helpful, I expanded the investigation to other logs.
I was able to find related error messages here instead.

%USERPROFILE%\Connect\logs\Server\

Reviewing the log files, the printer seems to be at fault. The output is processed and output creation completes.

To approach diagnosis, we have split the larger print job into two, both halves of the job appear to print fine. We’re now considering how to reduce the size of a single print job so they are handled by the printer.

1 Like