OL Learn

MySQL Database SSL & External Connections

Hello everyone,

We’ve just recently installed PReS Connect Server, Workflow, and Designer on our development Windows 2016 VM server.
I’ve been getting mixed information about how the Designer is supposed to work, in terms of getting my colleagues to access the Connect Server via Designer on their local PCs. When I click on “Send to Workflow”, it just tells me that there is no workflow instance. Since the Designer can see the workflow on the localhost as 127.0.0.1, I’m assuming that our PCs will have to connect to the MySQL database to be able to see the instances (please correct me if I am wrong).

In that case, is there a way that I can allow external connections (local network only) to the MySQL database, and enabled SSL on said connections? I did check the box at install time to disallow outside connections to MySQL (our third party did not mention if it was needed for Designer connections, so better secure than sorry, right?).

Actually, this has nothing to do with the MySQL database. You simply need to tell Workflow which computers are allowed to send files to it(i.e. Templates, DataMapper Configs, Job and Print Presets).

To do that, log on to the Workflow machine and launch the Workflow Configuration tool. Go to the Tools tab and select Access Manager, where you’ll be able to set the permissions. More information about this is available in the online help: http://help.objectiflune.com/en/pres-workflow-user-guide/2019.1/Default.html#cshid=5435

Ahh! Thanks for that link! That helps!

I did try adding the computer in question to the Access Manager, giving it all permissions. It still gave me the same message about there being no instance of the workflow in the Designer. Now, I just have Designer installed on the client. Nothing else. Do I have to install the Connect Workflow on all client machines too, just to get it to talk to the main server? I can try just manually adding the subnet, but I would prefer that it uses the automatic detection.

First things first: as stated in the online help, you have to stop/restart the PReS/PlanetPress Messenger service for the changes made in the Access Manager to take effect. This has to be done on the machine where Workflow is installed.

On the Designer side of things, you have to make sure that the PReS/PlanetPress Messenger service is running (it is that module that communicates with other Messenger services on the network and that relays the information to other Connect and Workflow modules). By default it is installed with Designer and set to launch automatically at Widnows startup, so you should simply check that it is currently running.

Note that if your computers are located on different subnets, auto-detection will not work. We wouldn’t want the Messenger service to broadcast its presence to the entire planet! If that’s the case, you will have to manually enter the subnet of the computer(s) to which you want to grant access.

Let me know if that helps.

Yes, I did restart the services whenever I made a change in Access Manager on the server. Even went back to make sure to restart the messenger service within the Service Console.

As for my client machine, the PReS Connect installer doesn’t give me the option to install the Messenger. It only gives me the option for Connect Designer, Connect Print Manager, Connect Server, Connect Server Extension, and MySQL. This is version 2019.1.0.57806. I am assuming that the Messenger is bundled in with the Connect Server, or the Workflow installer. I would prefer not to install the whole Workflow, or Server on client machines if I can help it, but I may not have a choice.

Yes, the PCs and servers are on the same subnet. For the ones that are not (for example, a laptop), I can manually add those. That won’t be a big deal.

Thanks again

I just tried everything @Phil explained. On a VM I simply installed the Connect Designer alone . No Connect Server, no MySQL, no Workflow.

PPMessenger does appears in my list of Windows services and is running. I successfully sent a Template to the Workflow running on my workstation (host of my VM).

I also tried reproducing your error and simply turned off the PPMessenger service on the VM, and got the same error as yours.

If you have properly done everything that @Phil suggested, then it could be the following problem:

  • Your Anti-Virus has prevented the installation of PPMessenger
  • Something went wrong during the install
  • PPMessenger service is turned off on your workstation where you only have the Connect Designer

If it isn’t the latter, I suggest you open a technical support ticket through our website. A technician will remote at your site and help you troubleshoot the issue.

To add to @hamelj’s answer: Messenger is automatically installed along with the Designer, without requiring you to install any other module. So you should have it already installed, but perhaps for some reason it isn’t set to start automatically? Open your Windows Services and look for PReS Workflow Messenger (it may also be listed as PlanetPress Workflow Messenger, which is exactly the same application, just a different name).

Check that it is currently running and that its startup type is set to Automatic or Automatic (Delayed Start). If it is currently running, stop and restart it, just to make sure it updates its internal listing of the other servers to which it has been granted access to.

Thank you @hamelj for testing that out! I did forget to turn off the Antivirus on the client. I’m going to turn it off, and reinstall it. @Phil There were no PReS services anywhere to be found in Windows services. That was the next placed I looked after you mentioned that it should have been installed with Designer.

It very well could be that something went wrong, and it didn’t actually install it. Let me give that a try. If it doesn’t work, I’ll try a different machine (just in case), then I’ll contact tech support.

For some reason, I forgot to post this:

So I was able to install it on a Windows 8.1, and a Windows 10 system, and the Messenger service showed up right after the install. The system I wanted the Designer on originally is Windows Server 2012 on our development server. Can it only run Designer with the Messenger, if it’s a non-server OS?

Regardless, this solves my issue!