OL Learn

No data from WinQueue Input

Trying to do some data mapping into a HTML page off of a PDF print job. Nothing maps into the HTML document. I changed the workflow to output to XML. Printed the document in and the XML came out as

<SalesRep/ >
<WorkOrderNum/ >
<Contact/ >

If I run the same document thru in Debug, the XML file is correct

< SalesRep>Ben Tsibulsk i</ SalesRep>
< WorkOrderNum>K-68054< /WorkOrderNum>
< Contact>Matthew</ Contact>

Haven’t been able to figure out why there isn’t any data extraction of print but there is in Debug. Using the same PDF. Swapped over to a simple setup for testing

WinQueue Input => Execute Data Mapping => Send to folder

Any ideas what I’m missing?
Jerry

Hi @jnordbye

I would expect you to get the same results under these circumstances. As such I’d suggest getting in contact with your local support team so they can investigate this further for you.

Thanks

Alex Banahene

@jnordbye: when you run in debug mode, you are always bypassing the initial Input task, so the process runs with the sample data file you’ve selected. At run time, obviously, you are running with the actual job that’s captured from the printer queue. I have a feeling the captured job may not contain the expected data.

To make sure we compare apples with apples, add a Send To Folder Action task immediately after the WinQueue Input task. This will save a copy of the job to a user-defined folder. Then, in debug mode, use that saved copy as your sample job file and then you’ll be able to compare the results from debug with those of the runtime process.

Let us know how that turns out.

Hi Phil,
Looks like you’re correct, I added a send to folder right after the WinQueue input. I took that PDF and feed it back thru in debug and the XML file is missing the info. When I open this file up in Foxit I cannot highlight any text. That’s definitely the issue.

Jerry

So I switched from Foxit to Acrobat reader and now I get the fields filled out in the XML file.
Thanks for the tip Phil.

Jerry

So apparently, Foxit prints the job as an image, whereas Acrobat Reader prints it as a true PostScript file (which is what a PDF essentially is).

Glad to see this fixed it for you, if anyone else encounters the issue with Foxit, we’ll know what to tell them. So thanks for the feedback.