OL Learn

NodeJS server input post json data problem / Timeout

Hello there

I tried to implement the NodeJS server input with json input data but i think there is a issue with the handling of this kind of data: request doesn’t end end is running into a timeout. The workflow is not catching the posted data and when i dug deeper i did find, that inside of the WF folder the request does something weird. When i post xml form data to the same address the data is not handled as attachment. but when i post json format the WF is handling it as an attachment and is creating an folder and inside of it the json file. when i post a regular attachment there is no such folder.

It would be nice of someone else can test this out.

to create json request you can use: https://reqbin.com

Thanks tobi

as i can only post 1 image (why??) here is a link to the images:

anyone?

when i post an attachment to the server the request is beeing handled but the attachment stays in C:\ProgramData\Objectif Lune\PlanetPress Workflow 8\PlanetPress Watch\nodeJS\NODEJS-JSON-DEBUG subfolder. and the request is timing out.

Support had only the (not really) helpful hint to disable xml envelope. but i need this too, to check the request for validity

@phil?

Not quite sure how you’re uploading your data files, but it works on my side.
I used Postman to test it:


Notice I used multipart/form-data as the content type.

The 3 files that were uploaded were JSON, they were all received and processed by Workflow, using the following settings in the NodeJS input task:

I did the same with 3 JPG files and it worked as well.

By the way, if you want to send your JSON payload in the body of the request, then just make sure your request specifies a content-type of application/json (or even text/plain) and then you can embed the JSON code directly in the body of the request.
The same goes for XML in the request body: specify a content-type of application/xml

Thanks Phil for your fast response

Okay, thats weird. My request are from the Laravel framework (guzzle) but i checked them with https://reqbin.com and they seem valid.

AH and json is fun but the datamapper doesn’t understand json? Now i convert it to xml first.

I have to check again.

Tobi