Upland OL User community

PPR Design 7.6 - turkish Document

Hello,
I have to create my first document with turkish characters and I can´t get it to work.
Even if I create a text box and copy a text with turkish characters into it it will show the “normal” character instead of the turkish one on the document.

Here an example:
https://ibb.co/kqvc6Zr

I tried different encodings but nothing seems to work.
Can someone give me a hint on how to fix this?

Regards JTK

Most likely this has to do with the font you’re using, and the encoding of the inserted text.
The font need to support the encoding you need for the special characters.

Please note if you try to copy and paste Unicode text it’s not working at all as Designer 7 does not support Unicode.

What font and encoding you’re using for Style 1?

The text that I got is from an Excel file, so I assume it should be UTF8.
Copying it directly into PPR Designer did not work.

I tried online converters from UTF8 to ISO 8859-9.
Set the Style to Times-Roman, ISO-8859-9, but that also did not work.

PlanetPress Suite is a non-Unicode program and is therefore affected by the system code page, especially when dealing with data in a language other than the display language of the application.

First, please make sure that your system locale is set to Turkish. To change it, you need to navigate to:

  • Settings:
  • Time and language:
  • Region:
  • Related Settings - Additional date, time and regional settings:
  • Region - Change date, time, or number formats:
  • Administrative:
  • Change system locale

Then PlanetPress itself need to be configured to use the system locale rather than the display language locale.

language

I am not sure that this is indeed the source of the problem, but it’s worth trying.

Could you add a Turkish sample text please so I can try myself?

@fortiny
This server is not only used for turkish documents.
Would your suggested change not impact the other documents?

@MartinS
satın koşullarını şartlarına Teslim Şekli
Here some word with special characters, like the i without dot, or the s.

Yes, this would have a global impact.

It might still be worth trying it, perhaps on a separate computer, to help with the investigation.

Hello,
I tested around a bit more.

I converted the excel file to a UTF-8 CSV file.
Then converted this file in PlanetPress Production with the Encoding Converted Plugin to ISO 8859-9.

Now to the strange part.
When I load this file in Design and switch the style to ISO 8859-9 everythings working.
When I copy text from the same file into a text box that uses the same style, it is not working.