OL Learn

Print emoji icon


#1

Hi,

I have an issue printing Emoji icons.
They show in the preview, but when printing it returns an error.

is there a workaround?

LoggedApplicationException: There was an error running the data mapping process caused by Error executing DM configuration: DB Error during DM result persist worker (DME000150)
Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.7.1.v20171221-bd47e8f): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: java.sql.BatchUpdateException: Incorrect string value: ‘\xF0\x9F\x98\x89\x0A\x0A…’ for column ‘DATA’ at row 30
Error Code: 1366

Internal Exception: java.sql.BatchUpdateException: Incorrect string value: ‘\xF0\x9F\x98\x89\x0A\x0A…’ for column ‘DATA’ at row 30
Error Code: 1366
Incorrect string value: ‘\xF0\x9F\x98\x89\x0A\x0A…’ for column ‘DATA’ at row 30
Incorrect string value: ‘\xF0\x9F\x98\x89\x0A\x0A…’ for column ‘DATA’ at row 30 (DM1000031)

{“error”:{“status”:500,“message”:“LoggedApplicationException: There was an error running the data mapping process caused by Error executing DM configuration: DB Error during DM result persist worker (DME000150)\n Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.7.1.v20171221-bd47e8f): org.eclipse.persistence.exceptions.DatabaseException\r\nInternal Exception: java.sql.BatchUpdateException: Incorrect string value: ‘\xF0\x9F\x98\x89\x0A\x0A…’ for column ‘DATA’ at row 30\r\nError Code: 1366\n \r\nInternal Exception: java.sql.BatchUpdateException: Incorrect string value: ‘\xF0\x9F\x98\x89\x0A\x0A…’ for column ‘DATA’ at row 30\r\nError Code: 1366\n Incorrect string value: ‘\xF0\x9F\x98\x89\x0A\x0A…’ for column ‘DATA’ at row 30\n Incorrect string value: ‘\xF0\x9F\x98\x89\x0A\x0A…’ for column ‘DATA’ at row 30 (DM1000031)\n”,“parameter”:""}}


#2

Try setting the connectionCollation of MySQL to utf8mb4_unicode_520_ci.

You can do this in the Connect Server Configuration > Database Connection page.

Set the connectionCollation property to utf8mb4_unicode_520_ci


Then restart both the OLConnect_MySQL and OLConnect_Server services.

Alternatively, use base64 svg images in your template rather than directly inserting emoji icons.


#3

this solution works! thank you!