OL Learn

Rest Request Json datamapper

hi everyone,
All-In-One Service - I am trying to generate a pdf on the Process All-In-One (Adhoc Data) service.
Datamapper config json (basic)
template basic pdf
I didn’t do any customization in output.
job default
I got the following error when I tried the cookbook example page.

Also, when I send the same service to the workflow and try
I get this error;

i don’t know where i went wrong

It’s hard to say without looking that the involved resources but this error typically occurs when the data mapper failed to populate one or more fields in the data model. If you replace the all in one task with the individual output steps you may be able to find out where the exact issue is and fix it.

Hi,
I am mapping with a very simple json data like a blog post(https://learn.objectiflune.com/blog/data/json-data-type/).
but when i run it in workflow i get the following error. I didn’t fully understand what the problem was.

Is there an full example(datamapper,designer,workflow) converting from json to pdf I can follow?
Or I shared the sample json data and the attached datamapper file. Can you give me an idea?

Error:

There was an error running the data mapping process caused by ApplicationException: Error executing DM configuration: TimeOut. Requested plugin JSON is not registered (DM1000031) (SRV000012)

rest_optic-map.OL-datamapper (5.2 KB)
{
“data”: [
{
“cover”:true,
“documentType”: 6,
“issue”: “exam”,
“uid”: “10580214”,
“name”: “Melissa”,
“lastName”: “Bozan”,
“number”: “0022”,
“schoolId”: “6632”,
“school”: “Deneme Okulu”,
“gradeId”: “6”,
“classId”: “552432”,
“designation”: “4B”,
“examNo”: “2”,
“eid”: “19493”,
“instanceId”: “37328”,
“exam”: “Okulistik Etkinlik Uygulamaları 1”,
“session”: 1,
“cityId”:34,
“townId”:19,
“schoolNo”:“0322”,
“city”:“İstanbul”,
“town”:“Kadıköy”,
“length”:2,
“grade”:4,
“sections”: [
{
“session”: “1”,
“sectionId”: “1”,
“courseId”: “10”,
“courseAlias”: “Türkçe”
},
{
“session”: “1”,
“sectionId”: “2”,
“courseId”: “11”,
“courseAlias”: “Matematik”
},
{
“session”: “1”,
“sectionId”: “3”,
“courseId”: “12”,
“courseAlias”: “Fen Bilimleri”
},
{
“session”: “1”,
“sectionId”: “4”,
“courseId”: “13”,
“courseAlias”: “Sosyal Bilgiler”
},
{
“session”: “1”,
“sectionId”: “5”,
“courseId”: “37”,
“courseAlias”: “Din K. ve Ahl. B.”
},
{
“session”: “1”,
“sectionId”: “6”,
“courseId”: “26”,
“courseAlias”: “İngilizce”
}
],
“maskId”: “08”,
“changeId”: {},
“maskData”: {},
“changeData”: {},
“labelData”: {},
“examCode”: “00663203732808”,
“qrCode”: “0066320373280800221”,
“fileName”: “37328_10580214”
},
{
“documentType”: 6,
“issue”: “exam”,
“uid”: “20169212”,
“name”: “Halil”,
“lastName”: “Test”,
“number”: “7832”,
“schoolId”: “6632”,
“school”: “Deneme Okulu”,
“gradeId”: “6”,
“classId”: “552432”,
“designation”: “4B”,
“examNo”: “2”,
“eid”: “19493”,
“instanceId”: “37328”,
“exam”: “Okulistik Etkinlik Uygulamaları 1”,
“session”: 1,
“cover”:false,
“sections”: [
{
“session”: “1”,
“sectionId”: “1”,
“courseId”: “10”,
“courseAlias”: “Türkçe”
},
{
“session”: “1”,
“sectionId”: “2”,
“courseId”: “11”,
“courseAlias”: “Matematik”
},
{
“session”: “1”,
“sectionId”: “3”,
“courseId”: “12”,
“courseAlias”: “Fen Bilimleri”
},
{
“session”: “1”,
“sectionId”: “4”,
“courseId”: “13”,
“courseAlias”: “Sosyal Bilgiler”
},
{
“session”: “1”,
“sectionId”: “5”,
“courseId”: “37”,
“courseAlias”: “Din K. ve Ahl. B.”
},
{
“session”: “1”,
“sectionId”: “6”,
“courseId”: “26”,
“courseAlias”: “İngilizce”
}
],
“maskId”: “08”,
“cityId”:34,
“townId”:19,
“schoolNo”:“0322”,
“city”:“İstanbul”,
“town”:“Kadıköy”,
“grade”:4,
“changeId”: {},
“maskData”: {},
“changeData”: {},
“labelData”: {},
“examCode”: “00663203732808”,
“qrCode”: “0066320373280800221”,
“length”:2,
“fileName”: “37328_10580214”
}
]
}

Which version of Connect are you using?
I have tried your datamapper in Connect 2021.2.1 and didn’t get your error.

Planet Press Connect Version 2021.1.1
Planet Press Workflow Version 2021.1.2

I guess I am not authorized to upgrade to Version 2021.2.1.
Because Update Manager says “No available updates”.

If you have a valid OL Care contract, yes you should. If not, then I suggest you enroll! Make your life much simpler :wink: