OL Learn

Save output file to specific destination folder but with original filename and PDF extension

I need to create a PDF from XML data that has a random filename. (ex 423_water.xml)

I need to have the PDF output saved to d:\output-location.

I must be doing something wrong in the Workflow because the “Send to Folder” is not controlling the location of the resulting PDF output.

The output location is going to be determined by your Output Preset. You can either define a destination path within your preset or you can use the “Through Workflow” option in the “Create Output” action in the Workflow configuration. Doing so will instruct Connect to give the finished XML file back to the Workflow as the new data file. That file can then be output to any location via the “Send to Folder” action.

https://help.objectiflune.com/en/planetpress-workflow-user-guide/2019.1/#Workflow/TasksProperties/OLConnect-CreateOutput.html

I must be doing something wrong because only the job file (job01055VC6EBKD13DC4491FE1.dat) is being moved over to the folder specified in the “Sent to Folder” action.

Here are screenshots of my “Create Output” and “Send to Folder” actions:

Here is a screenshot of my output folder:

There are no recent PDF’s found there.

You’ve got your Create Output step configured to use the value in %o for the name of the Output Preset that should be used.

%o, by default, would only contain the original name of the incoming data file. So it is likely not actually matching to any of your current Output Presets. You should see this mentioned in the logs that no match was found.

Try selecting the last one in your list instead: PDF Output.

That preset is currently defined to output to a folder, but by using the Through Workflow option, you’re overriding that instruction. You’ll get the PDF back as your datafile in the workflow.

Finally, your Send To Folder is configured with %o as the output filename, meaning even if a PDF is created, you’re going to have whatever name and file extension are stored in that variable. You’ll likely want to use a different filename mask. Try something simple for now, like %u.pdf. This should give you a random string and the correct file extension. You can refine it from there.

The %u did work, however, it is still a text file and not the PDF generated by the Create Output action

Hi Mario,

Don’t use %o in the output preset. (Since it is Original File Name i.e. your data as mentioned by AlbertsN) In your designer create a “Generic PDF” output preset. "Print presets->Output Creation Settings->Next->Embed Standard Fonts->Finish and save as “Generic PDF” and send to Workflow. Use that in the Create Output plugin.

You might want to make another one that also Prints Virtual Stationary if you have jobs that use pre printed stock and need the virtual stationary for proofing.

EDIT: And… Set the Send to Folder file name to %o.pdf.

Regards,
S

To be clear, you’re not creating a PDF at this point because you have not specified a valid PDF based Output Preset in your Create Output step. Without a valid Output Preset, Connect doesn’t know what sort of file you want.