OL Learn

SOAP Input issue

Hello all

I am using Soap UI to test the Soap input in my work flow. I am getting the response as GetSOAPProcessList: SOAP.Allow file not found (for submitjob). PLease let me know where I am doing wrong. I have attached my request, response and workflow configuration. Appreciate all the help.

Thanks much

Request

     <ii_File xsi:type="xsd:base64Binary">PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4NCjxpeHE6Y3VzdG9tZXJzIHht

bG5zOml4cT0iaHR0cDovL3d3dy5pcGVkby5jb20vWFF1ZXJ5RXhhbXBsZSI+DQoJPGN1c3RvbWVy
Pg0KCQk8Y3VzdG5vPjkwMDA8L2N1c3Rubz4NCgkJPG5hbWU+DQoJCQk8Zmlyc3RuYW1lPkpvZTwv
Zmlyc3RuYW1lPg0KCQkJPGxhc3RuYW1lPkFuZGVyc29uPC9sYXN0bmFtZT4NCgkJPC9uYW1lPg0K
CQk8ZW1haWw+am9lQG5vd2hlcmUuY29tPC9lbWFpbD4NCgkJPHBob25lPjEtODg4LTU1NS0xMjM0
PC9waG9uZT4NCgk8L2N1c3RvbWVyPg0KCTxjdXN0b21lcj4NCgkJPGN1c3Rubz4xMDAxPC9jdXN0
bm8+DQoJCTxuYW1lPg0KCQkJPGZpcnN0bmFtZT5BbmR5PC9maXJzdG5hbWU+DQoJCQk8bGFzdG5h
bWU+U2hhcGVyZDwvbGFzdG5hbWU+DQoJCTwvbmFtZT4NCgkJPGVtYWlsPmFuZHlAcGxheWFsbGRh
eS5jb208L2VtYWlsPg0KCTwvY3VzdG9tZXI+DQoJPGN1c3RvbWVyPg0KCQk8Y3VzdG5vPjEwMDM8
L2N1c3Rubz4NCgkJPG5hbWU+DQoJCQk8Zmlyc3RuYW1lPkFtYW5kYTwvZmlyc3RuYW1lPg0KCQkJ
PGxhc3RuYW1lPkpvaG5zb248L2xhc3RuYW1lPg0KCQk8L25hbWU+DQoJCTxlbWFpbD5hbWFuZGFA
YXJleW91c3VyZS5jb208L2VtYWlsPg0KCTwvY3VzdG9tZXI+DQoJPGN1c3RvbWVyPg0KCQk8Y3Vz
dG5vPjIwMDU8L2N1c3Rubz4NCgkJPG5hbWU+DQoJCQk8Zmlyc3RuYW1lPkJpbGw8L2ZpcnN0bmFt
ZT4NCgkJCTxsYXN0bmFtZT5NdXJwaHk8L2xhc3RuYW1lPg0KCQk8L25hbWU+DQoJCTxlbWFpbD5i
aWxsQHhtbGZvcm1lLmNvbTwvZW1haWw+DQoJPC9jdXN0b21lcj4NCg0KPC9peHE6Y3VzdG9tZXJz
Pg==</ii_File>
<ir_SubmitJobInfStruc xsi:type=“urn:TSubmitJobInfStruc” xmlns:urn=“urn:RemoteTypeCls”>
archiveXML
bobo.xml

</ir_SubmitJobInfStruc>
<ib_ReturnJobFile xsi:type=“xsd:boolean”>false</ib_ReturnJobFile>
<is_Username xsi:type=“xsd:string”>?</is_Username>
<is_Password xsi:type=“xsd:string”>?</is_Password>
</urn:SubmitJob>
</soapenv:Body>
</soapenv:Envelope>

Response

  <NS1:SubmitJobResponse xmlns:NS1="urn:soapActIntf-ISoapAct">
     <return href="#1"/>
  </NS1:SubmitJobResponse>
  <NS2:TSubmitJobResult id="1" xsi:type="NS2:TSubmitJobResult">
     <SubmitSuccess xsi:type="xsd:int">-1</SubmitSuccess>
     **<SubmitMessage xsi:type="xsd:string">GetSOAPProcessList: SOAP.Allow file not** found</SubmitMessage>
     <SubmitJobInfStruc xsi:nil="true"/>
     <SubmitResultFile xsi:nil="true"/>
  </NS2:TSubmitJobResult>

</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

My work flow configuration
image

Belated reply: set permissions through the Access Manager: https://help.objectiflune.com/en/pres-workflow-user-guide/2020.2/#Workflow/Interface/Access-Manager.html#toc-5