Upland OL User community

The function "registerListener" returned an error condition (0x80460004)

That is the error I got when I tried to proof a document to PDF. What is the cause and how to solve it?



The function "registerListener" returned an error condition  (0x80460004).
  com.objectiflune.core.base.ApplicationException: The function "registerListener" returned an error condition  (0x80460004)
  	at com.objectiflune.scheduling.TaskScheduler.submitAndWait(TaskScheduler.java)
  	at com.objectiflune.scheduling.TaskScheduler.submitAndWait(TaskScheduler.java)
  	at com.objectiflune.contentcreation.mergeengine.remote.MergeEngineTaskScheduler.submitAndWait(MergeEngineTaskScheduler.java)
  	at com.objectiflune.contentcreation.mergeengine.remote.ContentCreationOperation.a(ContentCreationOperation.java)
  	at com.objectiflune.contentcreation.mergeengine.remote.b.call(b.java)
  	at com.objectiflune.contentcreation.mergeengine.remote.b.call(b.java)
  	at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
  	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
  	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
  	at java.base/java.lang.Thread.run(Unknown Source)

Edit: This happens with multiple available PDF output presets.

“Print” also fails with multiple different error messages. One of them:


and another one: After the “print” error above, another subsequent try to start the “print” command from the Menu leads to this:


I was able to print (instead of “proof print”) after a restart of Designer.

However if I do multiple consecutive prints, after two or three I again get the “Enter Credentials” message.

Are you using external resources in your Template? In case this is true then I would like to suggest you to take the information, as documented under the heading External resources in Connect on the webpage ‘Known Issues - PlanetPress Connect version 2023.1 User Guide (link)’, into account.

Because german support warned us that network drives can create problems (after working for over 12 years with Suite 7) we relocated resources to the servers C: drive, so there are no external resources on network drives in this template that need to be addressed via an UNC path.

The only external resources are output and job settings and translation files. Those are on C:

Network drives do have some limitations, one of which we are working on removing in 2023.2.

That registerListener error is a known issue that can occur when the merge engine tries to report an error. The error can be about absolutely anything, and unfortunately there’s no way to tell what it was - it gets completely obscured. The issue is fixed in 2023.2.

I’m not aware of any issues with request headers. I can’t imagine any large headers aside from the auth token, which can’t be the culprit since according to your screenshot you’re not using authentication. Very strange.

Correct, because of diffuse problems in the past we deactivated auth after german support told us to do that.

It is a nuisance having to restart the software after multiple prints to get rid of this message, but as a workaround we can live with that.

But I wonder if this may happen if the template is used in production?

i stil have this problem and my question about if this may happen in production was not answered … In addition: This was the first print I tried, it did not work. For a software with printing as the core competence this is not encouraging …


I suppose that start checking the Server and Designer logs is a good starting point.

The Connect logs can be found on the following location: C:\Users\{Username}\Connect\logs