OL Learn

Trying to set up SQL Server instead of MariaDB

image

In the installer I entered the IP Address for the Host, the Instance was the same as the BiOS Name and the Schema I entered was olconnect. I even tried it w/ and w/o the database olconnect existing. I also created a login in SQL Server even though we will be using Windows Authentidcation. But is still fails to connect to the database. what am i doing wrong?

I had to enable TCP/IP in SQL Server

sqlsvr

for anyone else reading this, the 2022.1.5 installer is broken. You cannot natively install SQL Server directly. You must install MariaDB first. Also, you cannot uninstall MariaDB because of the break. There is no planned release with this fixed until maybe 2024. There also is no documentation stating what the latest version of SQL Server supported is. Just that SQL Server 2012 is the least version… and it is no longer supported by MS.

I am sorry you ran into issues with the installer. I have tried installing OL Connect on a brand new VM where I had already installed MS SQL Server 2019. I made sure to enable the TCP/IP protocol on the DB Engine, and also to enable mixed authentication mode (because the installer does not support Windows authentication):
image

I did not create a database schema ahead of time. I launched the OL Connect installer and unticked the MariaDB option. Later in the process, I was asked to enter connection parameters to the database:

As you can see, I specifically entered a schema name that’s different from the default (MyOLConnect, instead of olconnect), just to make sure a new database would be created automatically the first time OL Connect is launched. When I clicked on Test Connection, the attempt was successful, and the rest of the installation proceeded as expected.

I was immediately able to run a data mapping operation without any issue.

So I wouldn’t say the installer is broken. Let’s just say that in your case, you ran into an issue.

I should also have mentioned that you can uninstall MariaDB after the fact by going to the Control Panel, selecting PReS/PlanetPress Connect and then clicking on Modify. This will launch the installer again, from where you can untick the MariaDB option. Obviously, you’ll have to provide an alternative DB engine.

Gosh, I am sorry you could not replicate the problem I was having in PlanetPress Connect in Pres. OK, not really. That is a different product. I am not surprised that you had a different result.

If you doubt my results or comments, I ask that you read the entire ticket chain and that you look at what I have done on my VM by remoting in with me, which would have happened under OL, but apparently not under Upland.
If I sound upset, it is because I am. I have discovered on my own, that versions prior to 2022.1 have no problem installing natively to SQL Server, even though I was told they could not. I installed 2020.2 and had no problem. Truly, you broke the installer in 2022.?. If you doubt it, read the ticket history where an OL tech admits to that. BTW, it is a different installer than 2020.1 and apparently a different installer than whatever version of Pres you installed.
I had great respect for your answers in the past, but I must say that you put your opinions in perspective now.

btw, you cannot uninstall MariaDB in the installer for PPC 2022.1.5 at all. i ask that you try it

I had issues with installing 2022.1 against a SQL Server with TCP-IP enabled, but with dynamic ports. This didn’t work at all. You have to bind the db server instance to a fixed port in the configuration.
I also think, there is a problem in the installer, because connecting to an SQL Server instance without a port (when the server is configured for this) is not a problem, using a jdbc driver…

Please see my other ticket (sorry, I am logged in from home and not work and don’t have the ticket number) It has an OL support person saying that they broke the installer in 2022 and it cannot install SQL Server. I also include a description of how to install w/ SQL Server after installing MariaDB, which cannot be uninstalled from 2022.1.5

@jkornit : my statement may have been unclear. I have absolutely no doubt that you ran into issues with the Connect Installer, I certainly did not mean to imply otherwise. What I meant to say is that, on my system, when following the process I outlined, I didn’t run into the same issues.

I just ran the entire process again on my VM. I installed Connect 2022.1.5 (whether you install PReS Connect or PlanetPress Connect is irrelevant, it’s the same installer for both).

As I mentioned in my previous post, there are a couple of pre-requisites: you must enable the TCP/IP protocol and you cannot use Windows Authentication. These limitations are not due to the OL Connect software itself, but rather to the Installer (and we are working on fixing them).

It is very much possible that these limitations did not exist with the previous installer (I didn’t have time to double-check). But my post aimed to explain how you can install Connect with a SQL Server instance without running into issues.

And that’s why I concluded by saying that making a blanket statement that the Installer is broken for everyone is not entirely accurate. That isn’t a judgment on your own experience, and if it came across as such, I am deeply sorry.

@iiliev: yes, it is possible that the installer does not allow for dynamic ports. There are limitations to what the installer can do, as opposed to the application itself. We are hoping to solve those issues in future versions.

I apologize if my previous statements appeared to be dismissive of real, documented issues. I only aimed to offer information on how one may avoid, or work around them.