Customer requested an option to not reject data received going to un-named LPD queues so a single LPD input (un-named queues) can process the data in a generic process.
I added the suggestion to an existing ticket, we have other improvements planned for the LPD Input, so we might as well take a look while we’re at it…
They didn’t ask specifically for this, but how about the concept of a queue name mask where you could use a wildcard such as “LP_*” would grab “LP_1”, “LP_2”, etc.?
hmmmm… .for technical reasons that would be too painful to explain here, wildcards would be a lot more complex to implement. Part of the improvement to the LPD Input task already calls for multiple queue names inside a single input task (similar in that to the Folder Capture or HTTP Input tasks), and that would pretty much fulfill your request. You will just have to list all input queue names instead of using a wildcard, which I think is an acceptable compromise for now.
Sure that would still be a great addition