Upland OL User community

Unable to update div box paragraph or colour styles


I have a template that is using a .tif file image as the base of the template. (similar idea if it was used as virtual stationary or a background image) I have a number of div boxes and images. The div boxes have formatted text in them. For some reason, I can’t edit a newly added div box anymore. I can change the font, font type and size but I can’t update the paragraph spacing or colour. There are a few existing boxes that I can change and others I can’t.

Please let me know if there’s something I can do to fix this. (I’m not using the image as background in the section settings because I can’t control which page the image shows up on and I have 2 .tif images, 1 for page1 and 1 for page 2)

Thank you,

There was a random paragraph that wasn’t in a div box next to another div box not showing in the design window but was in the source window. I removed it and things seem to be working better, not perfect but better.

Thanks for reaching out. We received similar reports before and plan to improve div box editing in a future version (most likely 2023.1). Glad you were able to fix things in your template.

(internal reference: SHARED-87477, SHARED-87718)

I understand that the problem is that you don’t get a “Paragraph…” option when you right-click inside the div, which would open the Formatting dialog with a “Paragraph” tab.

That is not covered by the tickets Erik mentioned.

We only show that option if the selection contains child elements or parent elements with the following tags: p,li,pre,address,blockquote,h1,h2,h3,h4,h5,h6

So if you have the following HTML:

<div>Lorem ipsum</div>

You will not see the “Paragraph…” option since there is no child or parent element that matches those tags.

Just to add to that, we only show the “Text…” option if you have selected a non-empty range text. If the selection is collapsed you will not see that option.

I 'll create an improvement request to add an empty paragraph when creating a new box.

Thanks for all the insight guys.

So at this point it’s still hit or miss. I can format the text to a paragraph but the when I make an adjustment and click “apply”, the changes show on the template, then when I click “Ok” whatever was done is reverted to before I clicked it. I can get it to work by adjusting where the div box is in relation to the rest of the elements on the page in the Source window but even then I may have to try multiple times to get a change to stick. OR, If I remove ID="" from inside the span, I can make a change in some cases. For some div boxes, the attributes section on the right is is present but for the “problem” boxes, that tab is just blank.

I read on another topic a while ago about making changes to the box border and removing the class description from the attributes pane. But I can’t remove it if it’s not even an option to remove. I’m going to give it a go some more today and hopefully get enough of the template to behave appropriately. Then I will open a support ticket to see what is really going on.

Thank you, (Hope this make sense, I’ve tried to describe as best as I could)

If you done’t manage to get things solved it is prob best to have our Tech Support look at your template and if needed have it escalated to R&D.