OL Learn

Unkown Color Space

Hello,

I’m getting an error when trying to create a PDF output through designer. I have 1 duplex template which uses 3 different text font CMYK values. I am also using a few different look up tables through an ODBC xlsx data connection. Furthermore, I am using multiple dynamic images. I have other templates created in the same way but with a couple less fonts and images. The specific error I’m getting is:

An unspecified error occurred which was caused by LoggedApplicationException: There was an error running the output creation process caused by There was an error initiating to the output creation process caused by ApplicationException: Unknown color space nl.edmond.workflow.displaylists.colorspaces.DeviceNColorSpace (SRV000041) (SRV000001)

Any ideas?

Thank you,

With the information given, I get the impression that perhaps one of the images may be doing something special with regard to color that the output engine doesn’t support.
What version are you running? And are you creating vanilla PDF or one of the subtypes (PDF/A, PDF/X, etc.)?

Hi Manuel,

I’m running version 2022.1.4.10850. I’m creating a Vanilla PDF but also using optimize settings to decrease it’s size. I will go through the images, but there aren’t any images I haven’t used before. I will also try other troubleshooting methods.

Thanks for the reply.

If those images haven’t caused issues before, then my first thought might be wrong. I am happy to take a look at your template if it’s okay for you to upload that.

I’ve narrowed down the issue, I’m using a PDF in the media. When I print it without virtual stationary, it prints fine. But when I use the PDF is when I get the error. My template is too large to upload I believe, but it errors out during the upload.

Thank you,

WVC_WK1_Booklet_4up_wCARDs_EN_FR_PF_XMP_2_Print1.pdf (3.7 MB)

Here is an optimized version of the PDF I’m trying to use. (The full one is too large and doesn’t upload) This one doesn’t work either, but there are faint blue lines in it that might be the issue. When I import it to the designer, these blue lines don’t show up.
I’ve tried adding this PDF to the media and as an image.

That makes a lot more sense as an origin for this kind of issue.

I’m having a look at that PDF. At first glance it does have some interesting color spaces; page 2 has 134 color spaces, for instance. But page 1 and 3 also have a separation color space, and separations are mentioned in the error. I will need to hand it over to our devs to be certain which one is the culprit, and what can be done about it.
In the meantime, if you have the option to edit the source InDesign document, perhaps you could try to change those separation color spaces into a different kind of color space (assuming that InDesign gives you that kind of control).

The plot thickens: with the attached PDF as a background, I was not able to reproduce the issue. This was with the 2022.1.5 version and proof printing from the Designer (i.e., Connect Server was not involved).
I am not sure if 2022.1.4 versus 2022.1.5 would make that difference.

Do you still get the issue with a fresh template and only that background? (by the way, setting it as the section background instead of using it as virtual stationery will give you all 4 pages at once, if that’s what you need)

Okay, so I’ve upgraded to 2022.1.5 and have tried both a proof print and a regular print. I get the same error. I’ve also tried a fresh template with that as the background and still gives me the same error. Thank you for the suggestion of setting it as the section background, but I find flipping between medias easier so I can check for positioning with an FPO PDF behind.

Okay, now I was able to reproduce it. The error only occurs if the “Optimize images” settings are enabled.
So, you may have a work-around in turning those off (at the expense of a larger output file).

Now that I can reproduce it, I will have our developers investigate further.

One more detail: the problem seems to be with the second page (the one with 134 color spaces). When I only use page 1 of that background PDF, it still works with Optimize images.