OL Learn

Using an input mask to exclude specific files.


#1

I have set up a generic workflow process to accept most files for a processing. We are wanting to exclude certain files as their processes are different from most of the rest of production. I attempted to use the [!RN].xml mask to exclude all documents that are not to be picked up by the Capture folder that have the value of RN in the start of the file name. But it is picking up those files anyway. I tried checking the treat as regular expression option and that didn’t work and made the process worse. I also tried using a true regular expression which also did not work. Any guidance on what it is I am doing wrong with this process?


#2

The proper Regular Expression for this case would be:

^(?!RN).+\.xml

#3

Would the option “treat as regular expression” need to be checked for this expression?


#4

Thank you. That seems to have worked.


#5

Hi,

Sorry but I dont really understand the language. I try to import any txt-file that starts with nad but the does not contain rad.

There are 3 types of data
nad_15-05_tk.txt
nad_15-05_tv.txt
nad_15-05_rad.txt

I want my hotfolder to only pick up the first two.


#6

Well I do love Regular Expressions, but the use case you just presented stomps me.

I can match all filenames that do NOT contain string “_rad” with the following:
^((?!_rad).)*$

Or I can match filenames that start with “nad_” with this RegEx:
^(nad_).*$

But for the life of me, I can’t combine them into a single Regular Expression.

Does anyone else have an idea?


#7

Why not simply pick up all files and have a condition looking for Contains rad and branch out with a delete plugin? Or mask *tk.txt and *tv.txt or am I simplifying it too much?


#8

Thanks, I made a workaround. The first expression I can use, thanks for responding