Upland OL User community

W1534 Error while saving workflow

Hi there,

I’ve experienced this W1534 : Error while Saving the configuration file: Out of Memory in Workflow.

We’ve seen this happen a few times especially with you do an number of undo’s.

Is this a bug or something up with our install.

I can’t even close workflow configuration as I get the same error unless I close without saving an lose all the work I’ve done since last save.

If I try sending the configuration to the server I get a W1533 Error

Hi Michael,
Unfortunately this is a known issue. When you undo/redo changes in the workflow application, the amount of memory that the ppwfg.exe process uses increases. If the workflow application is never closed, this amount will continue to increase until it reaches a threshhold of around 1.5Gb, at which point it will corrupt your active config file. This is most likely what caused the error message.

To try and resolve this:
Make sure your Undo/Redo option is turned ON (in case you turned it off earlier)
Delete one of your processes. Pick the smallest possible one that you know you can recreate easily if anything goes wrong.
Try saving the config and check whether the file was saved properly

Before doing anything else, try Undo’ing the last action (when you deleted your process) to see if the application is able to recover it.

If the Undo method worked, it means you should be able to perform the above procedure several times until the save operation is successful. You may end up losing a few processes but it’s better than losing everything.

Note: If you have autosave enable in preferences, it’s possible you’ll have a config file with the extension “._as” in your PlanetPress Watch folder. If you have that file, you can change the extension to “.ol-workflow” and then load that configuration.

1 Like

I can’t believe this issue hasn’t been fixed yet, we have lost so may hours of work with the out of memory issue and has been going for for so many years