OL Learn

W3001 : Error while executing plugin: HTTP/1.1 500 ApplicationException: InvalidAccessError: A parameter or an operation is not supported by the underlying object

Hello,

I want to send emails through the Create Email Content Workflow Plugin. That worked fine for a while but now I get an error.

W3001 : Error while executing plugin: HTTP/1.1 500 ApplicationException: InvalidAccessError: A parameter or an operation is not supported by the underlying object.

Does anyone know what this error means in detail?
I restarted the server and everything works fine for some time. But after a while (I do not know if it happens after a time period or an amount of executions) the same error occurs permanently until I restart the server again.

Do you still have the issue?

If so, I suggest you open a technical support ticket through our website.

I had that issue one time again since opening that topic. But after a server restart it worked fine again and I did not get the error again. I have done various stress tests but could not find the cause for the error.
I think it was the server, maybe one of the mysterious windows things?!? :thinking:
EDIT: Another possibility is, that our email provider was the black sheep. For quite a while the provider had various problems with sending emails with attachement. Since last month the provider seems to be stable again.

I keep watching it and will give feedback in this topic when it appears again.

PS: It reminds me of the problem with NodeJS Server Input, where the communication in the first place does not work and whoops, after a while, without any changes, it works (NodeJS-Server-Input cannot process simple POST). I did not get deeper in that issue because it was a customer project, so I used HTTP Server Input instead of NodeJS Server Input.